Debug VPPlanetGenerator

Debug VPPlanetGenerator

Return to topic list

Fri Feb 27 16:38:24 2015   by   Ron Vantreese
I'm just wondering if we should continue debugging here instead of "News ..." ?


Let's try 3 tests:

Test 1: Run command-line equivalent.

1. Open DOS Window and go to "<Program Files>\VPPlanetGenerator\MogensenPlanet", where "<Program Files>" represents the location where your programs are installed... likely to be "C:\Program Files(x86)" or "C:\Program Files".

2. Decide on a destination where you will save an image... something like "<Target>" = "%USERPROFILE%\Desktop" (I like Desktop because files I need to see will appear right in front of me.)

3. Enter this command:

planet.exe -s 0.070046563057861 -w 799 -h 399 -m 1.000 -L 0.000000 -l 0.000000 -G 0 -g 0 -i -0.020000 -V 0.035000 -v 0.450000 -pq -C Lefebvre2.col -P > "<Target>\rendertest.ppm"

NOTE: The "-P" causes a PPM image output

4. View the image.


Test 2: Copy map files to your Documents Folder.

1. Copy map files from "<Program Files>\VPPlanetGenerator\MogensenPlanet" and paste them at "%USERPROFILE%\VP\PlanetGenerator". (Create VP\PlanetGenerator if it doesn't exist.)

2. Run VPPlanetGenerator and launch the Mogensen Planet Generator.

3. Drop-down the Colour Map and select "VP:<something>", such as "VP:Lefebvre2". Do other configurations (or perhaps don't change anything else except the seed).

4. Render it!

Test 3: Render a smaller image.

1. Launch Mogensen Planet Generator and set up configurations. Keep the default Colour Map.
1a. Alternately, select a "VP:<map>"

2. Change this configuration before rendering: Set Width to 79 and Height to 39 to create a very small image.

Let me know how the tests go.
 
Sat Feb 28 10:19:44 2015   by   Gregory Nikiforakis
I tried all three tests without success. I tested the planet.c file from the zip at the Mogensen's original page and it had a few errors. My thought is if the MogensenPlanet was faulty to begin with and VPPlanet Generator has nothing to do with it. I used Dev C++ Compiler and also notified Mr. Tobren. Maybe anyone else could check it out too.
 
Sun Mar 1 00:03:42 2015   by   Ron Vantreese
WOW! So nothing worked?

One last test before we fault planet.exe :) Move planet.exe to your Desktop, and the color maps too. Then run the command.

Compiling? I used GCC from MinGW.

If still not working, then another suspect is that there's something different between your PC and my PC. (Or so Sherlock Holmes might say.)
 
Sun Mar 1 18:04:02 2015   by   Gregory Nikiforakis
Nothing, again. I don't know what Sherlock Holmes would say, i'm not a genius. I know that at least he would check it out before he get into any conclussions. I don't have the proper knowledge to correct those errors i found, that's why i'm asking here. Otherwise I would have done it myself. In any case, anyone with proper skills, could please check it out?
 
Sun Mar 1 22:03:23 2015   by   Ron Vantreese
Do you mean that planet.exe is still giving you a solid blue image?

If so, it's Torben's turn to continue this troubleshooting.

Checking it out... yeah.. that's my limitation... it's not breaking on me.... so I depend on this Community to assist....
 
Mon Mar 2 10:41:32 2015   by   Torben
Instead of compiling from the source, try downloading the pre-compiled Windows executable from http://www.diku.dk/hjemmesider/ansatte/torbenm/Planet/

Place the executable in the same folder as the colour files, open a command-line window, change directory to the folder with the executable and the colour files and write the command

planet -s 0.1111 -pM -w 800 -h 400 -o test.bmp

This should place in the same folder a file called test.bmp.  Then open the file test.bmp with an image viewer (such as IrfanView).

If this works, the planet program is working correctly.  Now try to copy planet.exe and the colour files to the folder used by VPPlanetGenerator (like Ron mentioned above) and run VPPlanetGenerator like he described.
 
Mon Mar 2 14:19:40 2015   by   Gregory Nikiforakis
I dont't understand. I did what mr. Torben said and it worked. It successfully created a map. Then I replaced everything in VPPlanet Generator with mr.Torben's files and still it doesn't work. I don't know how to proceed.
 
Mon Mar 2 15:39:58 2015   by   Ron Vantreese
This is getting more mysterious....

Try yet another test... you have replaced planet.exe and the text map files with Torben's versions. Now copy the entire folder VPPlanetGenerator/ and paste it to ... say... your Desktop. Run VPPlanetGenerator.exe and see what happens.

This will expose substantial differences between Tiny C Compiler and MinGW's GCC Compiler.
 
Mon Mar 2 19:13:09 2015   by   Ron Vantreese
On 3rd thought, I see 2 different methods of producing the image.

1. The method my program uses end with " -P > result.ppm" - this is similar to " > result.bmp".

2. Alternate method ending with " -o result.bmp"

I'm just wondering if you get 2 different results. On *my* PC, I get the same thing.
 
Tue Mar 3 05:06:46 2015   by   Ron Vantreese
I had a long day.... rethinking...

from Max:
Hi Ron,

The 1st test works ! Too bad it's the least handy ! :D
Unfortunaly, the 2 other tests generate the same unicolor images.

Do you have any clue ?

Thanks !
========
Me (after a long day)
I'm suspecting the Unix text issue lines ending in "\n" vs DOS text issue lines ending in "\r\n" and the conflict of mixing them and getting .NET to handle them.
I will see about handling the lines differently in the next release.
========
Me (rethinking)
I will check the source code planet.c on reading text files. I know that TC works, but I'm thinking of MinGW and Cygwin too, and Windows. etc.etc. VPPlanetGenerator doesn't actually read the color files unless you try to edit it. The planet.exe (and any program) runs differently between running in Command, and running within a .NET Program.
 
Wed Mar 4 03:41:04 2015   by   Ron Vantreese
Here's a long-shot of a test.... Look for planet.exe at

https://onedrive.live.com/?cid=9E7DB242359A93F0&id=9E7DB242359A93F0!30215

and test it. Let me know if the unicolors disappear.
 
Wed Mar 4 16:54:24 2015   by   Gregory Nikiforakis
No it didn't, if you use VPPlanet Generator. It's normal for the opposite. Is it possible to upload the outdated versions of VPPG? If they are already uploaded can you post the link? I can test to see which versions are working for me and they maybe able to help us find out the problem by comparing them, or something.
 
Wed Mar 4 17:45:18 2015   by   Ron Vantreese
All versions of VPPG use the same planet.exe. I recompiled planet.exe using MinGW because runtime is faster (one test 11 seconds vs. 23 seconds). I didn't keep many older versions and unfortunately, this issue first appeared after my last purge. Perhaps tell me more about your PC.. which OS? Other setup information? I have a less-optimal build of planet.exe that I will provide tonight, the same (-O) optimization as originally provided. (I normally do (-O3).)

With more information, the better chance to setup to reproduce issue, where I can put a battery on it and resolve it.
 
Wed Mar 4 20:48:10 2015   by   Gregory Nikiforakis
I have no idea of any specifics of my PC that may causing the problem. I have Intel Quad Core 2.33GHz/Core, Windows 7 Pro x64, Nvidia Graphics (DX 11), .NET 4,5.2, Visual C++ 2013 and 3GB RAM. I have a PC more than capable of using a program like this one, unless there is something that may actually causing the proble that I am not aware of. About compiling, try using Dev C++, the one I use and found the errors of planet.c, and try to fix the errors.
 
Wed Mar 4 23:56:36 2015   by   Ron Vantreese
You're good.. I was hoping for something like Windows XP/2000/98 or something old.

One question... does planet.exe run differently via CMD vs VPPlanetGenerator? ie.. one produces unicolor and the other doesn't...
 
Thu Mar 5 00:41:08 2015   by   Gregory Nikiforakis
Yes. In CMD, planet.exe creates a map normaly, while in VPPG it produces unicolor.
 
Thu Mar 5 04:51:02 2015   by   Ron Vantreese
Even though I said I'll put up another planet.exe, I didn't this time. Instead, I put up a VPPL-Debug1.zip here:

https://onedrive.live.com/?cid=9E7DB242359A93F0&id=9E7DB242359A93F0!30215

Included is planet.exe that has been modified to list the colors it reads from the .col files.

Run VPPlanetGenerator, then look on your desktop for "VPPlanetGenerator-Debug.log" file. The last "line" says "Render Message" and has a bunch of numbers. Please show me the numbers, also the name of the map you used. And on my system the last line does repeat, so I'll be working on fixing it.
 
Thu Mar 5 14:18:07 2015   by   Gregory Nikiforakis
2015-03-05 15:16:41.918 Render Message: [0 0 0 0]
[1 255 255 255]
[2 255 255 255]
[3 0 0 0]
[4 0 0 0]
[5 255 0 0]
[6 107 185 200]
[110 195 230 236]
[130 212 237 241]
[131 179 220 141]
[160 204 233 166]
[180 224 234 197]
[205 242 223 193]
[230 201 175 152]
[245 210 206 220]
[255 255 255 255]
[255 255 255 255]

MAP: Mercator COLOR: Lefebvre
 
Thu Mar 5 19:53:38 2015   by   Ron Vantreese
Can you test the Stars and Clouds and tell me what you get?
 
Thu Mar 5 21:47:06 2015   by   Gregory Nikiforakis
Star program is working properly while Cloud program gives me an error, tested in both VPPG normal program and DeBug. The error says "Invalid floating point 'x,xxxxxxx'", where 'x' is a number I stated in "Fractal Dimension".
 
Thu Mar 5 22:07:18 2015   by   Ron Vantreese
To clarify, did the Fractal Dimension have "," or "." as the decimal point? And can you give me a few examples?
 
Fri Mar 6 05:03:46 2015   by   Ron Vantreese
I uploaded VPPL-Debug2. I noticed my P6 processor handled images differently; now it handles it similarly as handling other types.

Test 1: Run VPPlanetGenerator from VPPL-Debug2. Issue persists? Change the seed value and re-render. Is the unicolor different (even if slightly)?

Test 2: Download the planet.exe as suggested by Torben and replace the planet.exe in VPPlanetGenerator. If issue goes away, then let that be the HOT FIX.
 
Fri Mar 6 10:05:24 2015   by   Gregory Nikiforakis
Ok....
Fractal Dimension....The error is: invalid floating point '2,15000'.

2,15000 is the Fractal Dimension number i used in the program before rendering. If i change the number of fractal demension, the number of the error will change accordingly.

Test1: Issue persists. The unicolor isnt different at all.

Test2: No changes.
 
Fri Mar 6 13:36:45 2015   by   Ron Vantreese
I finally recreated the problem! :) :D Solution is imminent!
 

Return to topic list



New message:
Topic:
Posted by:

Type the values of the dice shown below:

Return to topic list